软件版本地狱

刚调试通一个Redis的pubsub的bug,现象是原本正常工作的listen代码不正常结束。琢磨了半天,试着pip freeze,然后发现工作正常的环境tornado-redis为2.4.4,不正常的为2.4.2。

解决方案如下

pip install tornado-redis==2.4.4

从Windows开发时代的DLL地狱,到最近一个同事折腾编译gcc3.8,软件版本地狱一直伴随着程序员们。

感叹一下。

喜欢这篇文章就分享到微博吧!
留言请发送到
微信公众帐号
“技术派”

修订历史:


知识共享许可协议

关注@好看簿的蚂蚁

探讨技术、设计、人文和商业
相关的创业话题